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Adobe InDesign CC 2018
Troubleshooting How-to Guide
What do you do when InDesign CC 2018 (and past
versions) is crashing? Here is a checklist of ideas.

Generalities
1. Isolate the source problem
Is the problem the InDesign application, or something
wrong with your file? InDesign won’t start, or file won’t
open, or file opens and crashes, or crashes on same page?

2. Do you have enough RAM?

8. Same problem in a new file?
Do you get the same problem in a new file, or does
it only happen in one problem file? This can help you
determine if its the InDesign application or a corrupt file.

9. Move from network to hard drive
Working on a network server drive can work OK. But,
if you are having trouble, try packaging the InDesign
file (File > Package) to a folder on your local hard drive,
and work local. Network problems can cause crashing.
InDesign 2017 and newer is better at network drives.

You need at least 16GB of RAM to run effectively.

10. Keyboard shortcuts not working

3. Restart your computer

Usually caused by a 3rd-party software, possibly a
browser plug-in. Try rebooting and loading InDesign.
If it works, then load the browser and see if it breaks.

Quit InDesign, restart your computer, and try to start
it again, with no other programs running.

4. Run your Mac or Windows Utilities
Before you start any programs, try running housekeeping
operating system utilities like DiskWarrior or CCleaner
before starting InDesign again.

5. Force a screen redraw
Sometimes the screen is not redrawing. Try: Shift-F5 to
force a redraw. What looks like a bug will often vanish.
Cmd+Opt+/ (Mac) or Ctrl+Alt+/ (Win) will force InDesign
to recompose the text and also refreshes the screen.

6. Windows 10: Required Fonts
See Font Settings. There is a Check Box to “Hide fonts
based on language settings.” Also “Restore default font
settings” will help in case you delete fonts you needed.

7. Round up the usual font suspects
Font Doctor can diagnose and repair fonts, a common
reason for crashing.
http://www.extensis.com/font-management/
fontdoctor/
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11. Missing File Info dialog
Missing the File Info dialog? Locate and delete the
DVADialogPrefs.xml file and restart InDesign CC 2018.

12. Component Information dialog
Hold down the Cmd key while you choose InDesign >
About InDesign (Mac), or the Ctrl
key while you choose Help > About
InDesign (Win). The Component
Information dialog can tell you
potentially useful info about the
history of your file.

13. User cannot start InDesign
With admin privileges, create a new user and launch
InDesign. This will tell you whether or not the user
account is corrupted.

14. Updating to InDesign CC 2018
While installing, Import previous settings and preferences
seems to trigger many operational issues. Turn this off.
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Resetting InDesign

InDesign is crashing

15. Reset (aka trashing) preferences

16. Turn off Type Contextual Controls

Custom preferences are written to file each time you
quit InDesign, but can get corrupted if it crashes.

Preferences > Advanced Type > Type Contextual
Controls. This is a new feature that shows you alternate
glyphs. In CC 2017, this feature proved to be buggy. Try
turning them off.

Simply delete them and restart. InDesign will write a
new set of preferences. Press modifier keys immediately
as/after you click on the InDesign icon. Press
Cmd+Opt+Ctrl+Shift (Mac) or Ctrl+Alt+Shift (Win). Click
Yes to this message:

If you want to to protect a backup copy, do this:
1 Start InDesign CC 2018 (or your older version)
2 Open Scripts panel (Window > Utilities > Scripts)
3 Right-click on the User folder, and choose Reveal in
Finder (Mac) or Reveal in Explorer (Win)
4 This is a folder named Scripts Panel in the Mac Finder or Win Explorer. Go one level above this folder
to the preferences file named InDesign Defaults. If
you make a backup copy of this file, you can restore
it (copy it back) if the original file becomes corrupt.

To reset manually, delete InDesign Defaults and InDesign
SavedData files, and restart InDesign.
Here is the folder location for the InDesign Defaults:
Mac OS: Home > Library > Preferences > Adobe
InDesign > Version 13 > en_US > InDesign Defaults
Windows 10: Users > UserName > AppData >
Roaming > Adobe > InDesign > Version 13 > en_US
> InDesign Defaults
Here is the folder location for the InDesign SavedData:
Mac OS: Home > Library > Caches > Adobe InDesign
> Version 13 > en_US >
Windows 10: Users > AppData > Local > Adobe >
InDesign > Version 13 > en_US > Caches >
I usually visit this Caches folder to delete the InDesign
SavedData file (when I manually reset preferences by
finding and deleting InDesign Defaults and InDesign
SavedData), but you might need to go into the InDesign
Recovery sub-folder and delete all the files inside if you
are caught in a restart/crash loop.
Some say the keyboard method works better than the
manual file delete method. In worst cases, some users
delete all files under these two folder locations.
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17. Turn off GPU Performance
If you are using InDesign CC 2015.4 (or later) on a
GPU-equipped Mac with Retina display, disable the GPU
Performance feature in Preferences > GPU Performance
or View > Preview on CPU and see if your problem stops.

18. Close docked and floating panels
Sometimes files crash with certain panels open, but when
the panels are closed, the file doesn’t crash. A quick
way to temporarily hide all panels on the screen is to
press the Tab key (when you don’t have text selected),
or Shift-Tab to hide all panels except the Tools panel.

19. Remove third-party plug-ins, if any
The most common problem is font activation plug-ins,
since they rely on the OS, InDesign, and the plug-in all to
work well together. Try shutting down font management
software. Look in the Plug-ins folder in the InDesign
folder in Applications (Mac) or Program Files (Windows)
to remove plug-ins from InDesign.

20. Crash on Print or Export to PDF
First, try the export to IDML trick. Next, try the Divide
and Conquer technique. If you isolate a page, move half
the objects to the pasteboard and test again.
If it is a graphic, open the graphic file and re-save to a
new filename and different format. Place it back onto
the page. If it is a textframe, copy the text out to a text
editor to remove all formatting. Try to replace back in.

21. Reinstall InDesign CC 2018
You might try to uninstall and then reinstall InDesign
using the Creative Cloud app. Some run the Adobe
cleaner utility before reinstalling:
https://helpx.adobe.com/creative-cloud/kb/
cc-cleaner-tool-installation-problems.html
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22. InDesign Auto Recovery crashing
InDesign temporarily saves, or caches, information
about the documents you are working on, so that
they can be recovered if InDesign crashes. When you
restart, InDesign attempts to recover and reopen the
problem file, causing it to crash again, and the process
repeats. The solution to this is to delete the cache files.
The files are located here:
Mac OS: Home > Library > Caches > Adobe InDesign
> Version 13 > en_US > InDesign Recovery >
RecoveryData (or even the whole folder)
Windows 10: Users > Username > AppData > Local >
Adobe > InDesign > Version 13 > en_US > Caches >
InDesign Recovery > RecoveryData (or whole folder)

23. Win 10: Recent Files
Right-click on the InDesign icon in the taskbar. Under
“Recent” there were files that InDesign kept looking for.
Right-click on the file and “Remove from this list.” Shut
down InDesign with Task Manager and then restart
normally might remove issues.

Hidden files
24. Mac OS: show Library folder
The user Library folder is hidden in Mac OS (10.7 and
later). Use one of the following methods to make the
user Library folder visible.
Method 1: In the Finder, choose Go > Go to Folder. In
the Go To Folder dialog box, type ~/Library. Click Go.
Method 2: Hold down the Option key when using the
Go menu. The user Library folder is listed below the
home directory. Note: After you open the Library folder,
drag the Library icon from the top of window to the
Dock, sidebar, or toolbar, making it readily accessible.
Method 3: Launch Terminal, type the following: chflags
nohidden ~/Library and press Return. Enter the system
admin password, and press Return. Close Terminal. The
Library folder is now permanently visible in the Finder.

25. Win 10: AppData folder is hidden
In Windows, open File Explorer and go to Tools > Folder
Options > View Tab, and then scroll down and check
the radio button to show hidden files and folders.
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Salvage the document
26. Export to IDML
IDML (File > Export > InDesign Markup IDML) is a way
to write an InDesign document to XML code. Export to
IDML, then close the original file, and open the IDML
to a new file sometimes cleans the file of corruption.

27. Divide and conquer
Delete half the pages, and see if the problem goes
away. If so, now you know which half of the file is the
problem. Return to the original file, and remove half
of the section you previously removed. Keep deleting
segments of the file to narrow the problem to a single
page or pages. Rebuild those pages to heal the problem.

28. Push damaged pages into a new file
Use the Move Pages command in the Pages panel
menu to push pages from a damaged document into
a new document with the same page setup.

29. Delete a text frame
A single corrupt story can be the source of the problem.
Try exporting all the text, then deleting one or more
of the text frames and see if the problem clears. If so,
replace the exported text into new text frames.

30. Delete a graphics frame
Actually, any frame object can be the source of crashing.
Try deleting a frame object to resolve crashing.

31. Delete styles and swatches
Try deleting (first the unused) paragraph, character,
object, table, and cell styles, and color swatches, and
see if the problem clears.

32. Export text to recover assets
Sometimes you need to get the text out of the file so that
you can rebuild the project. Try exporting the text (File
> Export > Text Only), or try ExportAllStories.jsx script.

33. Convert a PDF to a new InDesign file
Try exporting to PDF, and using PDF2ID to convert
back to InDesign.
https://www.recosoft.com/products/pdf2id/
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34. Acrobat DC’s Export To command

41. Mac OS: avoid system dfonts

Acrobat’s File > Export To command can extract to a
Word .docx or PowerPoint .pptx so that you can rebuild.

Mac OS: Avoid using system .dfonts in documents.
Remove old PostScript Type 1 fonts. Use only OpenType
versions of fonts. Don’t have multiple versions installed.

35. DTP File Recovery Service
Markzware offers a File Recovery Service. You pay
the larger fee only if they are able to recover your file.
http://markzware.com/products/file-recovery-service/

Preventive advice
36. Save-As frequently
InDesign files are databases of all the objects that
you’ve ever placed on your page, even those that
you’ve deleted. Occasionally do a File > Save As and
just save over the original file. This will compact and
clean up the file, keeping the database small, and less
prone to corruption.

37. Keep a chain of version backups
Practice saving iteratively-named backups. If the
document corrupts, you can go back to a workable
version without much loss. If you save your files in
Dropbox, its auto-versioning feature makes backups.
A free plug-in called Radish also saves versions for you.

38. Don’t build in a single document
Some say it is better to break the large project into
smaller files, and use the Book feature (File > New >
Book) to help manage the individual document files.

39. Don’t fill pasteboard with objects
Don’t store objects on the pasteboard, the area beyond
the page. It makes the file larger, and printing slows
down. Instead, use Libraries (File > New > Library) and/
or CC Libraries (Window > CC Libraries) to store extras.
Or make XML Snippets (File > Export > InDesign Snippet)
for storing objects that you might re-use later.

40. Mac OS: reset font caches
A frequent cause of app crashing. Use FontNuke utility
to remove and reset Mac OS font caches:
https://www.jamapi.com/products/fontnuke/

42. Use linked graphics
Don’t copy and paste artwork from Illustrator and other
programs into InDesign. This makes the file more prone
to corruption. Instead, always use File > Place to place
.ai and .psd graphics. If InDesign always crashes on a
particular page, it might be that placed graphic that is
corrupt; therefore replacing the placed (not pasted)
graphic can be an easier operation.

Get assistance
43. Adobe help documentation
Damaged documents:
https://helpx.adobe.com/indesign/kb/troubleshootdamaged-indesign-documents.html
Recover InDesign documents:
https://helpx.adobe.com/indesign/kb/indesigndocument-recovery.html

44. Adobe InDesign user forums
Research your questions on these two public forums:
https://forums.adobe.com/community/indesign
https://indesignsecrets.com/forums

45. Outside help
No guarantees, but Adobe might be able to help: email
or link your file to corrupt_indesign_docs@adobe.com.

46. Known issues
Do your own research by searching for “known issues”
https://helpx.adobe.com/indesign/kb/known-issuesoctober-2017-release.html
https://helpx.adobe.com/indesign/kb/indesign-andmac-os-high-sierra.html
https://helpx.adobe.com/indesign/kb/crash-fixesoctober-2017-release.html

47. Get a service contract
JetSet Communications is a great resource for services
related to InDesign and long-document productions:
http://trainingonsite.com/help-services.html ■
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Ask about our support services

InDesign | InCopy | Adobe Creative Cloud | tablet | EPUB | folio
Section 508 | Illustrator | Photoshop | Acrobat | Captivate | FrameMaker
mikewitherell@jetsetcom.net | Adobe Certified | urszulawitherell@jetsetcom.net
train with us at JetSetcom.net and TrainingOnsite.com in person
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